Wednesday, September 2, 2009

TORCS Championships 2009 - E-track-1

Aaaargh. Another race that I've messed up :(

Following Ruudskogen, we raced on E-track-1 this time. The track is nice, fast & rolling but has a tricky part, a bus-stop like chicane. If you do it right, you a) don't hit the wall b) don't crack your suspension c) carry enough momentum to have a decent finish-straight top speed.

Well, I've posted a version of my robots where the code that makes them negotiate the chicane was just missing. Result? Car enters the chicane too fast, hits a curb, flies a bit in the air and crashes against the wall, then spends 5 seconds finding the way out of the bus-stop. Then after 5 laps, the car is damaged enough to visit the pit for a 50-sec repair. Hillarious, right? Only time they did the maneuveres right were when they were about to overtake or let overlap someone.

After watching the same happen about 5 times I got quite angry and did not shoot any more screenshots until the race finished, sorry. So you can just see the start, some spins, dangerous Greens, fast JDIs, solid Dummies, evolving EJs, newbie grey Nexus (good performance!) and fighting but again loosing Wdbees.

What is missing? Right: no USR or Hymie in the race. Andrew decided to pull off his robot from the racing scene as he cannot spend enough time tuning them. Personally I don't agree with that and am very sad, but it is his decision so we must accept it. But...
Andrew, if you hear it - come back soon or... or... yarrrrr!!!

Results here, screenshots below without comments this time:

No comments:

Post a Comment